IT Help Desk Service Outage – Ticketing System

Incident Report for SCSU System Status

Resolved

This incident has been resolved. We will continue to monitor the system health. Support can be found by caling 203-392-5123, emailing helpdesk@southernct.edu, or by using our Chatbot at https://helpdesk.southernct.edu.
Posted Dec 11, 2025 - 08:36 EST

Identified

The SCSU IT Help Desk is currently experiencing an outage with our Anthology-managed ticketing system, which is impacting our ability to process and respond to work orders. Our team remains available to assist you, and we will continue to receive requests by email at Helpdesk@southernct.edu and by phone at 203-392-5123. Thank you for your patience as our vendor works to resolve this issue.
Posted Dec 10, 2025 - 09:41 EST
This incident affected: IT Help Desk.